Get in touch
Back
Resolved

Problem with email delivery for some users in Europe

Started 3 Jun at 10:42pm GMT+3.

Mailing Services
Created

Issues with email delivery to the users in the European region.
our team is investigating the issue currently.

Posted 3 Jun at 10:42pm GMT+3.